読者です 読者をやめる 読者になる 読者になる

ちゃっくのメモ帳

ちゃっくがメモしときたいことをメモしとくよ

tmuxをビルドしたんだよっ

ubuntu15.10でtmuxをaptで入れてもバージョンが2.0とかしか入らないので最新版を使うためにはソースからビルドする必要がある。

cd /usr/loca/src
sudo git clone https://github.com/tmux/tmux.git
cd tmux
sudo ./autogen.sh
sudo ./configure --prefix=/usr/local
sudo make
sudo make install

としてビルドすることができた。
もしこれでエラーが出たら

sudo apt-get install libevent-dev

とかしてみるといいかもしれない。

感想

aptを使って入れられるのが一番楽なんだけどaptを使うと古いバージョンだったりするから結局最新版を使うためにはビルドする必要があるのちょっと面倒くさいよね(o_o)....